Installation sous Windows Vista ?

Recoupe toutes les discussions à propos de Noalyss
polito65
Messages : 10
Enregistré le : mar. nov. 14, 2017 10:35 pm

Installation sous Windows Vista ?

Message par polito65 » mar. nov. 14, 2017 10:35 pm

Je tente d\'installer PhpCompta sous Windows Vista, pour une utilisation en local.

J\'ai suivi scrupuleusement les explications du fichier manuel_win2.odt

Ok pour EasyPhp même s\'il m\'a fallut consulter plusieurs forums pour trouver qu\'il fallait quitter Skype pour libérer le port 80 pour Apache qui sinon refusait de fonctionner.

Par contre lors de la décompression de Postresql-8.3.4, j\'ai le message suivant :
\"Impossible d\'ouvrir le package d\'installation. Vérifiez qu\'il existe et que vous êtes autorisé à y accéder, ou vérifier auprès de votre revendeur d\'applications que ce package de Windows Installer est valide.\"

Y a-t-il un package installable sous Vista ?

Je compte bien passer sous Linux prochainement, mais en attendant...

Merci

polito65
Messages : 10
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par polito65 » mar. nov. 14, 2017 10:35 pm

Trouvé la solution pour installer postgresql.
Blocage suivant : dans la config pgAdmin :
1. Refus d\'utiliser mes comptes utilisateurs habituels. Obligé de créer un nouveau compte, bon.
2. Création de database phpcompta : refus pour Encoding Latin1. Accepte seulement WIN1252.

Merci pour l\'aide, parce qu\'après qques heures à tenter d\'installer, ...

dany
Messages : 2181
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par dany » mar. nov. 14, 2017 10:35 pm

bonjour, pour postgresql il faut ABSOLUMENT unicode mais il fallait le spécifier à l\'installation !!!

Donc désolé mais désinstaller postgresql puis réinstaller, il y a une étape où on demande l\'encodage et là il faut dire unicode (utf8)

Il faut bien utiliser ce manuel-ci
http://www.phpcompta.be/download/manuel_win2.odt

polito65
Messages : 10
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par polito65 » mar. nov. 14, 2017 10:35 pm

oui j\'ai suivi ce manuel.
Désinstallé postgresql avec le désinstalleur de Windows.

Mais apparemment laisse des base de données déjà créées, car en relançan l\'installation de postgresql et en spécifiant cette fois à ce niveau uft8, il me dit \"le répertoire de données spécifié n\'est pas vide. ... soit je ne dois pas initialiser un groupe de base de données, soit je dois en créer une nouvelle.\"

C\'est à dire ?
J\'ai effectivement des repertoires de data avec la date d\'hier (1ere instal). Je les balance tous à la corbeille ? Vont-ils être regénérés par la nouvelle install ?

Pour une installation laborieuse, c\'est laborieux!

PS : les notes d\'installation de postgresql \"à lire avant d\'nstaller\" renvoie un 404 notfound.

dany
Messages : 2181
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par dany » mar. nov. 14, 2017 10:35 pm

Mais non PhpCompta s\'installe comme une fleur, c\'est postgres et apache qui sont un peu plus lourd ;)

Les bases de données sont regénérées, attention si tu as des données pense aux backup (avec PgAdminIII)

polito65
Messages : 10
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par polito65 » mar. nov. 14, 2017 10:35 pm

Je retente l\'installation.
Sur un desktop en Vista, pas moyen de faire tourner Apache avec Easyphp.
Pourquoi je ne sais pas. Le message dit qu\'un autre serveur utilise ce port, mais pas réussi à détecter quoi. Portscan ne dit rien, antivirus à jour, parefeu ok.

Repris toute l\'install sur un laptop, aussi en Vista, mais sur lequel est installé Xampp.
Du coup, que j\'appelle sous FF http://127.0.0.1/phpcompta/admin/setup.php, j\'ai un Objet non trouvé error 404

avec htpp://127.0.0.1 j\'arrive sous xampp

Puis-je désactiver temporairement xampp ? J\'ai pas trouvé où.
Ou alors puis-je faire tourner Phpcompta sous xampp ?

Puis-je configurer un 2ème localhost ?

Je voudrais vraiment arriver à utiliser enfin phpcompta !

polito65
Messages : 10
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par polito65 » mar. nov. 14, 2017 10:35 pm

well, again and again.
repris tout à zéro en désinstallant xampp, phpcompta, easyphp, et postgresql.
mis à part que les liens ne sont pas à jour dans le document manuel_win2.odt, ça va jusqu\'à l\'installation de postgresql.

Là, au moment de la configuration du service PostgreSQL, j\'ai une erreur de compte. Il n\'accepte pas \"compta\" et \"phpcompta\", et refuse de les créer. Je laisse donc \"postgres\" comme proposé. J\'attribue un passw.

Mais j\'ai donc le même nom pour le superutilisateur des bases à l\'écran suivant, mais je veille à donner un autre mot de passe.

OK ensuite pour terminer l\'instal.

Mais au redémarrage du PC, pas de nouveau compte utilisateur \"postgres\". Je le crée en Vista avec le même mot de passe.

Je lance Easyphp.
Dans administration, je n\'ai plus l\'alias créé précédemment.

Dans Firefox, l\'url http://127.0.0.1/phpcompta/admin/setup.php renvoie un 404 notfound.

Qu\'est-ce qui cloche? Je suis dessus depuis des heures...

dany
Messages : 2181
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par dany » mar. nov. 14, 2017 10:35 pm

Tu ne peux pas utiliser EasyPhp et XAMP en même temps, normalement phpcompta peut fonctionner sous XAMP. Toute documentation sur ce sujet est le bienvenu. Au fait, tu installes PhpCompta pour une ASBL, une société ou apprendre la compta ?

polito65
Messages : 10
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par polito65 » mar. nov. 14, 2017 10:35 pm

oui c\'est ce que je me suis dit. Je suis pas assez à l\'aise encore pour tenter de faire tourner sous xampp, mais je verrai.
J\'ai donc désinstallé xampp et refait une install complète sur mon desktop.

Je coince au moment de la création du compte utilisateur pour le service postgresql.
Refus des comptes existant et non création des autres comptes.

Je n\'ai pas vu ailleurs sur le forum ce même problème, dû à Vista ? Pourtant postgresql s\'annonce comme compatible avec Vista.

C\'est une compta pour une asbl qui démarre.
J\'ai travaillé longtemps sous Popsy mais je cherche une alternative opensource.
merci

polito65
Messages : 10
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re:Installation sous Windows Vista ?

Message par polito65 » mar. nov. 14, 2017 10:35 pm

j\'ai en fait exactement la même erreur que le post #448 :
Mais je suis sûr d\'avoir mis AllowOverride All à la création du virtual server.
Ne serait-ce pas lié au problème de création de user dans postgre ?

(pour accéder en FF, j\'ai bougé (copié/collé) tout le répertoire phpcompta qui était à la la racine de c: vers c:\\www\\ - Ceci n\'est pas tout à fait clair dans le tuto.)

merci

Warning: require_once(config_file.php) [function.require-once]: failed to open stream: No such file or directory in C:\\www\\phpcompta\\html\\admin\\setup.php on line 72

Fatal error: require_once() [function.require]: Failed opening required \'config_file.php\' (include_path=\'.:../../include:../include:addon:../../include:addon\') in C:\\www\\phpcompta\\html\\admin\\setup.php on line 72

Warning: Unknown: open(/tmp\\sess_beq8qds2e2p56celf8fhaicoq1, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

Répondre