erreur 500 apres install

Recoupe toutes les discussions à propos de Noalyss
Mario37
Messages : 19
Enregistré le : lun. avr. 02, 2018 3:21 pm

erreur 500 apres install

Message par Mario37 » lun. avr. 02, 2018 9:19 pm

Bonjour a tous,
je viens d'installer Noalyss sur mon hébergeur O2switch après la mise en place de la bdd postgresql j'ai réussi a faire l'installation.

j'arrive sur la page d'accueil Se connecter avec version 7001 indiqué en haut a gauche et les conseils pour firefox en bas a gauche.

je rentre donc mon login et le mdp phpcompta et la je me retrouve avec une erreur 500

j'ai chercher sur le forum mais rien ne correspond a mon probleme, exemple on parle de htaccess et je n'en ai pas vu un seul !!!

je suis passé en Debug pour voir les erreurs et là, y en a un paquet mais je ne sais pas interpreter tout ca :

Code : Tout sélectionner

select use_id, 
use_first_name, 
use_name, 
use_login, 
use_active, 
use_admin, 
use_pass,
 use_email from ac_users where lower(use_login)=lower($1)Array ( [0] => askdomiwebnoa ) SQL ERROR select use_id, 
use_first_name, 
use_name, 
use_login, 
use_active, 
use_admin, 
use_pass, 
use_email from ac_users where lower(use_login)=lower($1) ERREUR: la colonne « use_email » n'existe pas LINE 8: use_email ^

#0 /home/domiweb33/noalyss7/include/class/user.class.php (118): Database->exec_sql('select use_id,\n...', Array) 
#1 /home/domiweb33/noalyss7/include/class/user.class.php(78): User->load() 
#2 /home/domiweb33/noalyss7/include/admin_repo.inc.php(38): User->__construct(Object(Database)) 
#3 /home/domiweb33/noalyss7/html/admin-noalyss.php(34): require_once('/home/domiweb33...') 
#4 {main}ERREUR: la colonne « use_email » n'existe pas LINE 8: use_email ^
Fatal error: Uncaught Exception: SQL ERROR select 
use_id, 
use_first_name, 
use_name, 
use_login, 
use_active, 
use_admin, 
use_pass, 
use_email from ac_users where lower(use_login)=lower($1) ERREUR: la colonne « use_email » n'existe pas LINE 8: use_email ^ in /home/domiweb33/noalyss7/include/lib/database.class.php
:189 Stack trace: 
#0 /home/domiweb33/noalyss7/include/class/user.class.php(118): Database->exec_sql('select use_id,\n...', Array) 
#1 /home/domiweb33/noalyss7/include/class/user.class.php(78): User->load() 
#2 /home/domiweb33/noalyss7/include/admin_repo.inc.php(38): User->__construct(Object(Database)) 
#3 /home/domiweb33/noalyss7/html/admin-noalyss.php(34): require_once('/home/domiweb33...') 
#4 {main} thrown in /home/domiweb33/noalyss7/include/lib/database.class.php on line 189
c'est moi qui ai fait les retours a la ligne pour faciliter la lecture mais ca ne m'avance pas vraiment.
est ce quelqu'un pourrait m'aider a comprendre et a corriger mon (mes) erreur.
merci
Mario

dany2
Administrateur du site
Messages : 236
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re: erreur 500 apres install

Message par dany2 » lun. avr. 02, 2018 9:29 pm

Tu as installé la version mono dossier ou serveur ?

Mario37
Messages : 19
Enregistré le : lun. avr. 02, 2018 3:21 pm

Re: erreur 500 apres install

Message par Mario37 » lun. avr. 02, 2018 9:51 pm

ben je sais pas
je regarde mon telechargement et je reviens de suite

Mario37
Messages : 19
Enregistré le : lun. avr. 02, 2018 3:21 pm

Re: erreur 500 apres install

Message par Mario37 » lun. avr. 02, 2018 9:55 pm

je ne voie aucune indication, sur le site j'ai téléchargé la version-7.0, j'aurai du prendre la version noalyss-package ?

dany2
Administrateur du site
Messages : 236
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re: erreur 500 apres install

Message par dany2 » mar. avr. 03, 2018 7:00 am

Non non , tu as la bonne version.

Pourrais-tu me dire comment tu as installé ou me donner le lien vers la doc d'installation que tu as suivi ???

Bàt

D

Mario37
Messages : 19
Enregistré le : lun. avr. 02, 2018 3:21 pm

Re: erreur 500 apres install

Message par Mario37 » mar. avr. 03, 2018 12:40 pm

Bonjour Dany et merci pour ton aide.

j'ai suivi la méthode indiquée dans la doc
http://wiki.noalyss.eu/doku.php?id=inst ... e_o2switch
quand j'ai fait l'installation j'ai eu un message me rappelant mon identifiant et le mot de passe phpcompta mais chose curieuse mon identifiant a l'origine contenait des majuscules comme ceci MarioDuWeb et le message l'a écrit sans aucune majuscules marioduweb ?
je ne sais pas si ça peu avoir un rapport avec le problème.
a la connexion j'ai essayé les deux et ça ne marche pas.

Autre chose : dans la doc, il y a quelque chose que je ne comprend pas : (3è point) Ensuite, via le CPanel, on crée une base de données PostgreSQL. Pas besoin de lui affecter un administrateur : par défaut c'est le propriétaire qui .....
qu'est ce que ça veut dire ? dans la création de ma bdd j'ai d'une part la création de la bdd et ensuite je dois lui attribué un utilisateur est ce que c'est cet utilisateur qui est appelé administrateur et qu'il ne faut pas créer ??

A plus
Mario

dany2
Administrateur du site
Messages : 236
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re: erreur 500 apres install

Message par dany2 » mar. avr. 03, 2018 1:00 pm

Je vois , tout le monde confond le propriétaire de la base de données (utilisateur postgresql) et l'administrateur de noalyss.

Alors ce qu'on a voulu dire dans la documentation, c'est qu'il ne faut pas créer un utilisateur postgresql mais utiliser celui qu'on a et qui créera la base de données. Cela n'a rien à voir avec l'utilisateur noalyss qui lui peut se connecter au site , l'utilisateur postgresql fait le lien entre le site et la base de données.

Ensuite MarioDuWeb est le login (= administrateur de Noalyss), le login est insensible à la casse (majuscule = minuscule), donc ce n'est pas un soucis.

Normalement avec l'install.php, la base de données aurait du être mis à jour correctement.

Tu as exécuté install.php ?

Mario37
Messages : 19
Enregistré le : lun. avr. 02, 2018 3:21 pm

Re: erreur 500 apres install

Message par Mario37 » mar. avr. 03, 2018 1:24 pm

ok pour l'histoire des majuscules et minuscules.

oui, c'est bien ca, je passe par monsite/noa/html/install.php

par contre, excuse moi, mais je ne suis pas sur d'avoir bien compris : je dois refaire l'install sans créer d'utilisateur de bdd ?

bon le temps de recharger le tout et je fais un essai et reviens te dire.

a plus

dany2
Administrateur du site
Messages : 236
Enregistré le : mar. nov. 14, 2017 10:35 pm

Re: erreur 500 apres install

Message par dany2 » mar. avr. 03, 2018 1:53 pm

par contre, excuse moi, mais je ne suis pas sur d'avoir bien compris : je dois refaire l'install sans créer d'utilisateur de bdd ?
Oui c'est ça,
a- tu crées la base de données (l'utilisateur de db = celui de cpanel = propriétaire de la db)
b-exécuté mono.sql + script SQL pour la France / Belgique
c- aller sur install.php et suivre la procédure

Quand c'est fini , normalement tout doit fonctionner

Mario37
Messages : 19
Enregistré le : lun. avr. 02, 2018 3:21 pm

Re: erreur 500 apres install

Message par Mario37 » mar. avr. 03, 2018 2:28 pm

Voila ce que je viens de faire :
re upload Noalyss = dossier noalyss7
re création bdd = domiweb_noal3
re chargement du fichier mono-france.sql
re utilisateur de db

install = monsite/noalyss7/html/install.php

tout ce passe bien et il m'indique mon identifiant et le mot de passe phpcompta
je valide et j'obtiens ca : [url=https://www.noelshack.com/2018-14-2-152 ... h15-36.jpg]

et j'attends que le bargraphe avance mais rien ne bouge ?
est ce que ca doit bouger tout seul, ou bien il faut que je fasse quelque chose ?

Répondre